Bildröhreneinheit nichtlinear in y-Richtung?

alles was sich auf einzelne Teile bezieht

Moderator: suntri

Antworten
Benutzeravatar
JeanLuc7
Fast schon Admin
Fast schon Admin
Beiträge: 618
Registriert: 09.02.2011, 16:07
Wohnort: Berlin
Flag: Germany
Kontaktdaten:

Bildröhreneinheit nichtlinear in y-Richtung?

Beitrag von JeanLuc7 » 07.02.2019, 20:07

Salut Bastelfreunde,

wie man an anderer Stelle lesen kann, beschäftige ich mich derzeit hin und wieder mit einem Projekt zur Darstellung von Objekten und Texten auf der Bildröhreneinheit und auf TFT-Displays. Ich habe hier nun inzwischen auch zwei Original-Bildröhreneinheiten von Philips aus dem EE2007, und beim Ausprobieren fiel mir etwas auf, was ich zunächst einmal sehr ungewöhnlich fand. Aber schaut selbst:
Bild 1.JPG
Bild 1.JPG (125.95 KiB) 478 mal betrachtet
Bild 1.JPG
Bild 1.JPG (125.95 KiB) 478 mal betrachtet
Bild 2.JPG
Bild 2.JPG (111.89 KiB) 478 mal betrachtet
Bild 2.JPG
Bild 2.JPG (111.89 KiB) 478 mal betrachtet
Beide Bilder zeigen ein TV-Raster (x=15625 Hz, y=50Hz, 625 Zeilen), und darauf ausgegeben wird ein Kreuz in einem 12x12-Raster; jedes Kreuz ist dabei 24 Zeilen hoch - man sieht also 12 horizontale und vertikale Linien. Im Rastergenerartor hat der Sägezahn des fürs horizontale Signal hat eine kleine Delle, die man sieht, wenn man genau hinschaut - das wusste ich, und eine echte Behebung ist hier nur mit viel Aufwand möglich. Der Sägezahn für die Vertikalablenkung ist aber absolut linear, weil er mit einem digitalen A/D-Wandler erzeugt wird.

Bild 1 zeigt unsere Neubau-Röhre im Betrieb. Das Raster wird dort so exakt linear dargestellt, wie es sein soll. Bild 2 zeigt die BRE aus dem EE2007, und ganz offensichtlich ist das Raster dort nicht mehr linear. Ich habe es mit zwei Röhren ausprobiert - bei beiden sieht das Bild exakt gleich aus, weshalb ich einmal annehme, dass es sich dabei nicht um einen Fehler handelt.
194e.png
194e.png (304.47 KiB) 478 mal betrachtet
194e.png
194e.png (304.47 KiB) 478 mal betrachtet
Wenn man nun aber mal einen Blick in das Handbuch des EE2007 wirft, findet man dort Bild 194e - da sieht alles wunderbar linear aus. Und im Aufbau, der hier ebenfalls steht, passt es auch - das Testbild ist wunderschön linear. Wenn man sich nun das Ausgangssignal der Vertikalablenkung am Oszilloskop anschaut, stellt man fest, dass es gar nicht so wirklich vollständig linear ist - es hat eine Delle. Und witzigerweise weist sie in genau Gegenrichtung zu jener, die man anhand der Verzerrung meines Rasters erwarten würde. Mit anderen Worten: da wird wohl die eine Delle im Vertikalverstärker benutzt, um die andere Delle im Ablenkgenerator auszugleichen. Wenn man an der BRE die Anschlüsse 1 und 4 vertauscht, zeigt der Horizontalverstärker übrigens dieselbe Delle - beide Verstärker sind ja baugleich. Offenbar arbeiten beide nicht mehr vollständig linear, wenn sie es mit einem langsamen Sägezahn zu tun haben. In der BRE-Schaltung fällt mir da der C24 ins Auge - durchlässig für Wechselspannung und für hohe Frequenzen kein Widerstand. Er ist aber nur auf einer Seite bei T22 vorhanden, die Gegenseite mit Transistor T23 ist hier geringfügig anders gebaut - und ein Kondensator fehlt. Ich würde mal drauf tippen, dass das in diesem Falle sogar die Absicht der Philips-Designer war. BRE und der Fernsehkasten wurden ja gleichzeitig veröffentlicht.

Ich werde mir wohl jetzt behelfen, und meinem linearen Ablenkgenerator eine künstliche Delle verpassen, was zum Glück keine wirklich große Sache ist. Trotzdem: mit einem solchen Ergebnis hatte ich wirklich nicht gerechnet.

Es grüßt herzlich
JL7/Frank
Dateianhänge
Vertikaler Ablenkgenerator.png
Vertikaler Ablenkgenerator.png (515.61 KiB) 478 mal betrachtet
Vertikaler Ablenkgenerator.png
Vertikaler Ablenkgenerator.png (515.61 KiB) 478 mal betrachtet
Vertikale Ablenkschaltung.png
Vertikale Ablenkschaltung.png (205.03 KiB) 478 mal betrachtet
Vertikale Ablenkschaltung.png
Vertikale Ablenkschaltung.png (205.03 KiB) 478 mal betrachtet

Benutzeravatar
JeanLuc7
Fast schon Admin
Fast schon Admin
Beiträge: 618
Registriert: 09.02.2011, 16:07
Wohnort: Berlin
Flag: Germany
Kontaktdaten:

Re: Bildröhreneinheit nichtlinear in y-Richtung?

Beitrag von JeanLuc7 » 08.02.2019, 20:09

... und mit etwas mehr Aufwand bekommt man es dann doch hin. Mein vertikaler Sägezahn ist jetzt nicht mehr linear, sondern hat eine Delle nach unten - und damit wird das Bild schön linear, wie es sein soll.
Dateianhänge
Bild_3.JPG
Bild_3.JPG (111.18 KiB) 451 mal betrachtet
Bild_3.JPG
Bild_3.JPG (111.18 KiB) 451 mal betrachtet
BRE-Eingangssignal.png
BRE-Eingangssignal.png (25.18 KiB) 451 mal betrachtet
BRE-Eingangssignal.png
BRE-Eingangssignal.png (25.18 KiB) 451 mal betrachtet

Physiker66
Stammgast
Stammgast
Beiträge: 186
Registriert: 25.07.2017, 21:27
Wohnort: Albuquerque, USA
Flag: Austria

Re: Bildröhreneinheit nichtlinear in y-Richtung?

Beitrag von Physiker66 » 08.02.2019, 23:46

Gratuliere!

Hast du eine Idee warum das überhaupt notwendig ist?

liebe Gruesse
Michael
:oops: Selbst ein schlechtes Experiment bildet die Wirklichkeit besser ab als eine gute Simulation.

Physiker66
Stammgast
Stammgast
Beiträge: 186
Registriert: 25.07.2017, 21:27
Wohnort: Albuquerque, USA
Flag: Austria

Re: Bildröhreneinheit nichtlinear in y-Richtung?

Beitrag von Physiker66 » 08.02.2019, 23:53

Und eine andere Frage - es kommt mir so vor als wäre horizontal ein ähnlicher Effekt?

liebe Gruesse
Michael
:oops: Selbst ein schlechtes Experiment bildet die Wirklichkeit besser ab als eine gute Simulation.

Benutzeravatar
JeanLuc7
Fast schon Admin
Fast schon Admin
Beiträge: 618
Registriert: 09.02.2011, 16:07
Wohnort: Berlin
Flag: Germany
Kontaktdaten:

Re: Bildröhreneinheit nichtlinear in y-Richtung?

Beitrag von JeanLuc7 » 09.02.2019, 09:43

Hi Michael,

nun ja, ich hab es oben beschrieben: ich vermute, dass diese Nichtlinearität im Zusammenhang mit dem EE2008-Fernseher steht - damit das Fernsehbild auch mit der sehr einfachen vertikalen Ablenkschaltung sauber ausschaut, hat man diesen kleinen Kunstgriff getan. Beim EE2007-Oszilloskop fällt er kaum ins Gewicht, weil da schneller abgelenkt wird.

Der horizontale Sägezahn ist bereits auf meiner eigenen Platine nichtlinear, das sieht man dann auch auf dem Bildschirm. Hier kann ich keinen D/A-Wandler einsetzen, weil der Mikrocontroller dafür zu langsam ist. Man müsste ihn mit 720x15625Hz=11,25 MHz ansteuern, um ausreichend Linien (Pixel in x-Richtung) zu erzeugen. Das ist für den µC weniger als ein Takt. Daher habe ich mich hier für eine Ladeschaltung mit Transistor und Kondensator entschieden, wobei ich einen relativ geraden Teil der Ladekurve nutze und ihn dann per OpAmp verstärke.

Grüße, Frank/JL7

Antworten

Zurück zu „Bauteile, Baugruppen, Nachbauten, eigene Erweiterungen“